Keine Systemuhrsynchronistation + keine My Ebay Übernahme

Hier finden Sie:
- alle Informationen zu SchnapperPro
- Hilfe bei Problemen
- Antworten auf Fragen.
Antworten
Noppes
Beiträge: 5
Registriert: 11.07.2009, 09:48

Keine Systemuhrsynchronistation + keine My Ebay Übernahme

Beitrag von Noppes » 05.07.2011, 21:27

Hallo,

ich setzte den SchnapperPro in Version 2.0.54 ein. Mit der alten SchnapperPro (1.x) Version konnte ich eine Systemuhrsynchronistation durchführen, mit der neuen nicht mehr. Woran kann das liegen?
Mein Computer liegt hinter einem Proxy-Server und einer Firewall. Hier der Logdateiauszug:

05.07.2011 22:11:43(0) - - 31 - - ptbtime2.ptb.de Error! Number: 10061: Connection is forcefully rejected
05.07.2011 22:11:43(0) - - 31 - - ptbtime2.ptb.de Timeout
05.07.2011 22:11:44(0) - - 31 - - ntp3.fau.de Error! Number: 10061: Connection is forcefully rejected
05.07.2011 22:11:47(0) - - 31 - - ntp3.fau.de Timeout
05.07.2011 22:11:48(0) - - 31 - - time.fu-berlin.de Error! Number: 10061: Connection is forcefully rejected
05.07.2011 22:11:51(0) - - 31 - - time.fu-berlin.de Timeout
05.07.2011 22:11:52(0) - - 31 - - ntp2.fau.de Error! Number: 10061: Connection is forcefully rejected
05.07.2011 22:11:55(0) - - 31 - - ntp2.fau.de Timeout


Wenn ich Artikel von meinen EBay Beobachtungsliste übernehmen möchte, bekomme ich folgende Fehlermeldung:

Fehlernummer: 0
Beschreibung:
Programmteil: M_Ebay_Import
Zeile: 0

06.07.2011 06:22:56(0) - - 31 - - Verbindungstest 'CommClient.exe' erfolgreich.
06.07.2011 06:23:02(0) - - 31 - - Verbindungstest(https) 'CommClient.exe' erfolgreich.
06.07.2011 06:23:04(0) - - 31 - - GetDokument 1.7.3.186; Zeile 410: 10060: The current connection has timeout.
06.07.2011 06:23:04(0) - - 31 - - Verbindungstest 'SchnapperPro.exe' gescheitert.
06.07.2011 06:23:34(0) - - 31 - - Login begonnen [XXX]
06.07.2011 06:23:38(0) - - 31 - - GetDokument 1.7.3.186; Zeile 410: 10060: The current connection has timeout.
06.07.2011 06:23:42(0) - - 31 - - GetDokument 1.7.3.186; Zeile 380: 10060: The current connection has timeout.
06.07.2011 06:23:42(0) - - 31 - - Problem beim Login
06.07.2011 06:23:42(0) - - 31 - - Keine Daten vom eBay-Server erhalten. Internetverbindung oder Firewall prüfen.
06.07.2011 06:23:42(0) - - 31 - - Login beendet [XXX]
06.07.2011 06:23:42(0) - - 31 - - Mein eBay Import Teil 1/2 - gestartet

Mit der alten Version hatte ich diese Probleme meines erachtens nicht. Ansonsten läuft SchnapperPro reibungslos.

Vielen Dank für eure Hilfe.

Noppes

Benutzeravatar
Robert Beer
Administrator
Beiträge: 4566
Registriert: 11.03.2004, 15:40

Re: Keine Systemuhrsynchronistation + keine My Ebay Übernahm

Beitrag von Robert Beer » 06.07.2011, 09:16

Noppes hat geschrieben:Mein Computer liegt hinter einem Proxy-Server und einer Firewall.
Eine Firewall blockiert üblicherweise nur eingehende Verbindungen, das betrifft SchnapperPro nicht.
Vermutlich bockt der Proxy-Server. Sind denn die Einstellungen für den Proxyserver korrekt in SchnapperPro hinterlegt?
Viele Grüße aus Berlin
Robert Beer

Noppes
Beiträge: 5
Registriert: 11.07.2009, 09:48

Re: Keine Systemuhrsynchronistation + keine My Ebay Übernahm

Beitrag von Noppes » 06.07.2011, 09:50

Danke für ihre schnelle Antwort. Der Proxy ist richtig eingetragen, das bieten und aktualisieren klappt ja. Unsere Firewall blockiert tatsächlich auch ausgehende Verbindungen; Windows kann zum Beispiel sich nicht mit Zeitservern synchronisieren. Das interressante ist aber, das die alte Schnapper-Version einen zeitabgleich mit Ebay machen konnte, nur mit der neuen klappt es nicht.

Haben sie eine Idee?

Danke für ihre Hilfe

Noppes

Benutzeravatar
Robert Beer
Administrator
Beiträge: 4566
Registriert: 11.03.2004, 15:40

Re: Keine Systemuhrsynchronistation + keine My Ebay Übernahm

Beitrag von Robert Beer » 06.07.2011, 09:54

Noppes hat geschrieben:Unsere Firewall blockiert tatsächlich auch ausgehende Verbindungen
Dann müssen dort die Ports 80, 443 und 37 freigegeben werden. Dann sollte alles funktionieren.
Viele Grüße aus Berlin
Robert Beer

Noppes
Beiträge: 5
Registriert: 11.07.2009, 09:48

Re: Keine Systemuhrsynchronistation + keine My Ebay Übernahm

Beitrag von Noppes » 06.07.2011, 10:11

Welche Ports freiegeben sind weiß ich leider nicht... Der Port 80 auf jeden Fall :-)

Noppes
Beiträge: 5
Registriert: 11.07.2009, 09:48

Re: Keine Systemuhrsynchronistation + keine My Ebay Übernahm

Beitrag von Noppes » 13.07.2011, 22:05

Unser Netwerkadministrator wird unsere Firewall nicht verändern. Daher ist meine Frage funktioniert der Schnapper auch, wenn nur der Port 80 freigegeben ist? Funktioniert dann auch das Textmusterupdate? In meiner Fehlerlogdatei habe ich öfters die Meldung das die Benutzeranmeldung nicht richtig klappt. Kann das durch veralterte Textmusterdateis eind?

Vielen Dank für eure Hilfe

Noppes

Benutzeravatar
Robert Beer
Administrator
Beiträge: 4566
Registriert: 11.03.2004, 15:40

Re: Keine Systemuhrsynchronistation + keine My Ebay Übernahm

Beitrag von Robert Beer » 14.07.2011, 08:22

Noppes hat geschrieben:funktioniert der Schnapper auch, wenn nur der Port 80 freigegeben ist?
Um es noch einmal klar zu stellen: SchnapperPro benötigt keine eingehende Verbindungen, an richtigen Firewalls muss keine Änderung durchgeführt werden, die blockieren ja nur eingende Verbindungen.

Wenn allerdings ein 'Sicherheitsprogramm' installiert ist, das auch abgehende Verbindungen kontrolliert, müssen die Ports 37, 80 und 443 verfügbar sein. Das liegt daran, dass beispielsweise der eBay-Server Logindaten nur über verschlüsselte Verbindungen akzeptiert. Die gehen üblicherweise über den Port 443. Daran kann man auch nichts ändern.
Viele Grüße aus Berlin
Robert Beer

dernix
Beiträge: 25
Registriert: 22.08.2011, 20:27

Re: Keine Systemuhrsynchronistation + keine My Ebay Übernahm

Beitrag von dernix » 23.08.2012, 18:34

Hallo,

habe das gleiche Problem ... SchnapperPro kann seit einer Weile nicht mehr zu Zeitservern verbinden. Die Ports 37, 80 und 443 habe ich abgehend freigeschaltet.

Kann ich SchnapperPro auch einen eigenen Zeitserver, beispielsweise den Router benennen?

Danke und Gruß

Benutzeravatar
Robert Beer
Administrator
Beiträge: 4566
Registriert: 11.03.2004, 15:40

Re: Keine Systemuhrsynchronistation + keine My Ebay Übernahm

Beitrag von Robert Beer » 23.08.2012, 18:51

dernix hat geschrieben:Kann ich SchnapperPro auch einen eigenen Zeitserver, beispielsweise den Router benennen?
Nein. Das würde auch nichts am Problem ändern.
Wenn vom Rechner auf dem Schnapperpro ausgeführt wird, keine Zeitserver erreichbar sind, liegt ein erheblicher Defekt der Netzwerkverbindung vor.

Anhand der SchnapperPro Logdatei sollte sich der Zeitpunkt an dem es zu dem Fehler gekommen ist, relativ genau bestimmen lassen. Mit einer Systemwiederherstellung vor diesen Zeitpunkt müsste das Problem auch leicht wieder zu beheben sein.
Viele Grüße aus Berlin
Robert Beer

dernix
Beiträge: 25
Registriert: 22.08.2011, 20:27

Re: Keine Systemuhrsynchronistation + keine My Ebay Übernahm

Beitrag von dernix » 23.08.2012, 19:34

Robert Beer hat geschrieben: Nein. Das würde auch nichts am Problem ändern.
doch, würde es, denn mein Router fungiert als Zeitserver und auch der W7-Rechner, auf welchem SchnapperPro läuft, synchronisiert mit dem Router die Zeit. Wenn ich jetzt beim SchnapperPro meine Router-IP eintragen könnte, hätte SchnapperPro die richtige Zeit.
Robert Beer hat geschrieben: Wenn vom Rechner auf dem Schnapperpro ausgeführt wird, keine Zeitserver erreichbar sind, liegt ein erheblicher Defekt der Netzwerkverbindung vor.
... oder der Router arbeitet mit deny-all-Strategie.

edit: die Ports 37, 80, 123 und 443 sind freigegeben
Robert Beer hat geschrieben: Anhand der SchnapperPro Logdatei sollte sich der Zeitpunkt an dem es zu dem Fehler gekommen ist, relativ genau bestimmen lassen. Mit einer Systemwiederherstellung vor diesen Zeitpunkt müsste das Problem auch leicht wieder zu beheben sein.
Systemwiederherstellung gibts bei mir nicht und die Logdatei des SchnapperPro reicht genau so weit zurück, wie die Verbindungen zu Zeitservern blockiert werden.

Danke und Gruß

Benutzeravatar
Robert Beer
Administrator
Beiträge: 4566
Registriert: 11.03.2004, 15:40

Re: Keine Systemuhrsynchronistation + keine My Ebay Übernahm

Beitrag von Robert Beer » 23.08.2012, 19:59

dernix hat geschrieben:... oder der Router arbeitet mit deny-all-Strategie.
Da würde ich einen "Strategiewechsel" in Erwägung ziehen, oder den Router gleich stromlos betreiben. Dann ist eine vollständige Ablehnung aller Pake noch sicherer. :wink:
Viele Grüße aus Berlin
Robert Beer

dernix
Beiträge: 25
Registriert: 22.08.2011, 20:27

Re: Keine Systemuhrsynchronistation + keine My Ebay Übernahm

Beitrag von dernix » 23.08.2012, 20:05

die Bemerkung ist nicht wirklich hilfreich und nur in Maßen witzig. Zumindest bei Lancom-Routern ist deny-all eine übliche Strategie. Selbstverständlich werden bestimmte Ports und bestimmte Dienste gezielt durchgelassen, man muss sie nur einrichten.

Diese Ports habe ich mit UDP bereits extra für den Schnapper-Rechner freigegeben:
dernix hat geschrieben: edit: die Ports 37, 80, 123 und 443 sind freigegeben
allerdings ohne Erfolg. Macht der Schnapper ntp vielleicht über einen anderen Port?

Benutzeravatar
Robert Beer
Administrator
Beiträge: 4566
Registriert: 11.03.2004, 15:40

Re: Keine Systemuhrsynchronistation + keine My Ebay Übernahm

Beitrag von Robert Beer » 23.08.2012, 20:36

dernix hat geschrieben:Diese Ports habe ich mit UDP bereits extra für den Schnapper-Rechner freigegeben: allerdings ohne Erfolg. Macht der Schnapper ntp vielleicht über einen anderen Port?
SchnapperPro benutzt NTP überhaupt nicht, sondern verwendet das Time Protokoll über Port 37 TCP.
Das Time Protokoll ist zwar schon fast 30 Jahre alt, aber solange es genügend zuverlässige Server gibt, spricht nichts dagegen es zu verwenden...
Viele Grüße aus Berlin
Robert Beer

dernix
Beiträge: 25
Registriert: 22.08.2011, 20:27

Re: Keine Systemuhrsynchronistation + keine My Ebay Übernahm

Beitrag von dernix » 23.08.2012, 22:10

jo ... und jetzt noch einmal meine Bitte: eine Möglichkeit, eine eigene Netzwerk-IP als Timeserver statt der sonst bekannten ntp-Server einstellen zu können.

Danke und Gruß,
Dietmar

Benutzeravatar
Robert Beer
Administrator
Beiträge: 4566
Registriert: 11.03.2004, 15:40

Re: Keine Systemuhrsynchronistation + keine My Ebay Übernahm

Beitrag von Robert Beer » 23.08.2012, 22:34

Das Network Time Protocol ist etwas anderes als das Time Protocol. Beide Protokolle haben zwar fast die gleiche Zielsetzung, unterscheiden aber trotzdem deutlich. Insofern wäre es völlig sinnlos SchnapperPro die Adresse eines NTP-Servers vorzuschreiben, wo doch die Abfrage der Zeit per TP erfolgt.
Viele Grüße aus Berlin
Robert Beer

Antworten

Zurück zu „SchnapperPro“